【覚書】PHP のバージョンアップ

 

サーバで動作している、PHP のバージョンを一気に、5.6 から 7.1 に変更してみた。

レンタルサーバ(XServer)での作業だったので、モジュールのバージョンアップは、コンソールから簡単にできたのだが、動作させていた、Wordpress で問題が発生した。
キャッシュ系のプラグインが動作しなくなって、エラーを吐き出している状況になってしまった。

しばらく更新されていない。プラグインだったので、削除することで対応した。あとは、使っていない状況になっていたプラグインを削除したら、動作がかなり改善されたようだ。
もともと、実験の意味が強かったサイトだったが、実験の必要もなくなったので、運営体制に入ってみたのだが、実験時に組み込んだプラグインは、自分で作成したプラグインは使う予定がないので、一時的に削除することにした。

これから、PHPのバージョンアップを行う時には、二度手間にならないようにするためにも、プラグインは停止した状態でやっていくことにしよう。

プラグインが動いていない状況で、エラーになるようなら、しばらくPHPは動いているものをベースにしておくことにしよう。